Access NVR from the internet with Mikrotik port forwarding

I had to set up access to a Hikvision NVR on local network. Port forward from the public IP of ISP was done. My job was setting port forwarding on Mikrotik router which was connected to the NVR.

It was a lot of hours wasted until I figured it out from lots of forum reading and YouTube videos watching 😀

/ip firewall filter
add action=dst-nat chain=dstnat dst-address=192.168.100.115 dst-port=58000 \
    protocol=tcp to-addresses=192.168.88.3 to-ports=8000
add action=dst-nat chain=dstnat dst-address=192.168.100.115 dst-port=56911 \
    log=yes protocol=tcp to-addresses=192.168.88.3 to-ports=6911

The dst-address had to be the IP address of the router from the WAN side. Check in Quick Set

Mikrotik NAT port fowarding

Advertisements

Author: Michal Zuber

Full stack developer, biker and rollerblader. Owner and developer at https://nevilleweb.sk/ Co-founded http://neville.sk/ Blog at https://michalzuber.wordpress.com/

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s