EZVIZ C3W IP cam RTSP URL

Finally got the stream URL

$ mpv rtsp://admin:VERIFICATION_CODE_FROM_CAMERA@CAMERA_IP/
Playing: rtsp://admin:JFORKE@192.168.2.70/
[ffmpeg/demuxer] rtsp: Missing PPS in sprop-parameter-sets, ignoring
(+) Video --vid=1 (h264 1920x1080 15.000fps)
(+) Audio --aid=1 (aac 1ch 16000Hz)
File tags:
Title: Media Presentation
AO: [pulse] 16000Hz mono 1ch float
VO: [gpu] 1920x1080 yuv420p

Just replace CAMERA_IP with IP and VERIFICATION_CODE_FROM_CAMERA with your code from camera

More info at https://www.ispyconnect.com/man.aspx?n=EZVIZ

ezviz stream

Find malware on your web server/shared hosting

Some of my client websites get hacked. Some shared hosting providers provide some virus scanning tools, but it’s not always enough and what about those who even don’t provide malware scanning. Hopefully they provide SSH access and AI-BOLIT can be used. It’s a free website virus and malware scanner for websites.
Just download it, unzip and upload to your desired host. Copy it into the root directory of your website.
Last run it
php ai-bolit.php --mode=2
or not paranoid/normal mode
php ai-bolit.php

Switch from netctl to NetworkManager on Arch Linux

On my notebook I finally decided to try NetworkManager with its applet

After installing. I had to check status of some networking services and disable them.

systemctl status dhcpcd.service
sudo systemctl stop netctl.service
sudo systemctl stop netctl-ifplugd@eth0.service
sudo systemctl status netctl-ifplugd@eth0.service
sudo systemctl stop netctl-auto@wlan0.service

And then wait for the magic after starting NetworkManager
sudo systemctl start NetworkManager.service

network manager applet

I should have searched for a how to video on YouTube and could save some debugging time with journalctl -f 🙂 After setup I found https://www.youtube.com/watch?v=MAi9DurTRQc

Access NVR from the internet with Mikrotik port forwarding

I had to set up access to a Hikvision NVR on local network. Port forward from the public IP of ISP was done. My job was setting port forwarding on Mikrotik router which was connected to the NVR.

It was a lot of hours wasted until I figured it out from lots of forum reading and YouTube videos watching 😀

/ip firewall filter
add action=dst-nat chain=dstnat dst-address=192.168.100.115 dst-port=58000 \
    protocol=tcp to-addresses=192.168.88.3 to-ports=8000
add action=dst-nat chain=dstnat dst-address=192.168.100.115 dst-port=56911 \
    log=yes protocol=tcp to-addresses=192.168.88.3 to-ports=6911

The dst-address had to be the IP address of the router from the WAN side. Check in Quick Set

Mikrotik NAT port fowarding

Everything You’ve Been Taught About How To Read a Book Is Wrong

the main role of reading is improving your model of the world to more accurately reflect reality so that you can make better decisions.

The reason for reading a book is not to be able to spit back facts at a cocktail party — it’s to shape the way you think.

From https://taylorpearson.me/howtoreadabook/

Hack into your flow

“The average business person spends less than 5% of their day in flow. If you could increase that to 15%, overall workplace productivity would double,”

“The brain can’t tell the difference between physical consequences and emotional risk,” says Kotler. “Taking social risks is the same as physical risks.”

“In Silicon Valley, the idea is to fail fast or fail forward,” he says. “If you’re not giving employees space to fail, you’re not giving them space to risk. Move fast and break things. Engage in rapid experimentation. High consequences will drive flow and you get further faster.”

From https://www.fastcompany.com/3031052/how-to-hack-into-your-flow-state-and-quintuple-your-productivity

Splitting zsh config due multi host usage

This week while copying some of my dotfiles (due vim and zsh configuration) to a new remote host (dedicated server) of a new client I had to remove the private stuff (mainly aliases) from my .zshrc. Only now did the muse hit me to split the file and leverage the source (import, require, include) functionality.

So I moved the host specific and private stuff from .zshrc and added the following 2 lines after source $ZSH/oh-my-zsh.sh:

[[ -f .zshrc_priv ]] && source .zshrc_priv
[[ -f .zshrc_host ]] && source .zshrc_host

After editing .zshrc and moving some lines into .zshrc_priv and .zshrc_host I also commented the files header to be reminded about their purpose in the future 😀

# .zshrc_priv
# Sourced by .zshrc
# Private settings due public version control

alias vps='TERM=xterm-256color autossh -M 0 mike@vps' # host vps set in .ssh/config
alias vps_tunnel='autossh -f -M 0 -T -N -R 10022:localhost:22 mike@vps'
# .zshrc_host
# Sourced by .zshrc
# Host specific settings

export PATH="/usr/local/opt/node@6/bin:$PATH

Next I gonna separate some vim plugin specific code, too, to have a copyable (Plug & Play) config.

Three practically painless ways to expand your network — ideas.ted.com

You’ve worked out an efficient way of living your life, but you end up seeing the same people because they’re also following their own routines. Why not make your network slightly more inefficient? Go to a bathroom on a different floor, get your morning coffee from a different place, park in a different spot. You should encounter a new network of people.

Another way we get stuck in ruts is through filtering. We do this automatically and immediately. The minute we meet someone, we look at them and decide “You’re interesting” or “You’re not interesting” or “You’re relevant” or “You’re not relevant.”

When someone recently did something for you, did you just reply with a “Thank you,” “thx” or “ty”? Next time, say “Let me know if I can ever help you” or “I look forward to collaborating again.” Sentences like these can reinforce our ties with other people.

via Three practically painless ways to expand your network — ideas.ted.com