Access NVR from the internet with Mikrotik port forwarding

I had to set up access to a Hikvision NVR on local network. Port forward from the public IP of ISP was done. My job was setting port forwarding on Mikrotik router which was connected to the NVR.

It was a lot of hours wasted until I figured it out from lots of forum reading and YouTube videos watching 😀

/ip firewall filter
add action=dst-nat chain=dstnat dst-address=192.168.100.115 dst-port=58000 \
    protocol=tcp to-addresses=192.168.88.3 to-ports=8000
add action=dst-nat chain=dstnat dst-address=192.168.100.115 dst-port=56911 \
    log=yes protocol=tcp to-addresses=192.168.88.3 to-ports=6911

The dst-address had to be the IP address of the router from the WAN side. Check in Quick Set

Mikrotik NAT port fowarding

Advertisements

Timed WiFi enable/disable (MikroTik)

During sleep I don’t need WiFi and while the router is in my room where I sleep it would be health beneficial to sleep without WiFi signal.

Thankfully Mikrotik has some great features

First I needed scripts for enable and disable. After that they could be executed via Scheduler.

Screen Shot 2017-03-16 at 06.48.34
ss_2017-03-12-09-25-34
ss_2017-03-12-09-25-43
ss_2017-03-12-09-25-51
ss_2017-03-12-09-25-57