Google Play Music desktop player MPRIS media keys for Linux

I finally nailed it πŸ˜€
dbus-send --print-reply --dest=org.mpris.MediaPlayer2.google-play-music-desktop-player /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.PlayPause

dbus-send --print-reply --dest=org.mpris.MediaPlayer2.google-play-music-desktop-player /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Next

Also added to my Awesome window manager config
https://github.com/mikaelz/dotfiles/blob/f7e8246a06b9e91b5656419708c9c122f1aa4685/.config/awesome/rc.lua#L372-L375

Advertisements

SSH proxy via SOCKS with Firefox

Open dynamic port forward with SSH
ssh -D 8080 REMOTE_HOST

Then via Firefox visit about:preferences#general

Under Network Settings -> Manual proxy configuration set ONLY SOCKS host IP/DNS name and port.

firefox proxy settings

To test proxying go to https://www.whatismyip.com/ to check your public IP if it changed

Monitor progress of cp, mv, gzip, mysql and CLI commands

To monitor progress of an ongoing copy or mysql dump import you might try progress CLI tool. Track progress of commands like cp, mv, dd, tar, cat, rsync, grep, fgrep, egrep, cut, sort, md5sum, sha1sum, sha224sum, sha256sum, sha384sum, sha512sum, adb, gzip, gunzip, bzip2, bunzip2, xz, unxz, lzma, unlzma, 7z, 7za, zcat, bzcat, lzcat, split, gpg, etc.

Access NVR from the internet with Mikrotik port forwarding

I had to set up access to a Hikvision NVR on local network. Port forward from the public IP of ISP was done. My job was setting port forwarding on Mikrotik router which was connected to the NVR.

It was a lot of hours wasted until I figured it out from lots of forum reading and YouTube videos watching πŸ˜€

/ip firewall filter
add action=dst-nat chain=dstnat dst-address=192.168.100.115 dst-port=58000 \
    protocol=tcp to-addresses=192.168.88.3 to-ports=8000
add action=dst-nat chain=dstnat dst-address=192.168.100.115 dst-port=56911 \
    log=yes protocol=tcp to-addresses=192.168.88.3 to-ports=6911

The dst-address had to be the IP address of the router from the WAN side. Check in Quick Set

Mikrotik NAT port fowarding

Hikvision NVR camera stream watching on LG TV

LG Smart World contains the Smart IPTV app
ss_2018-10-13-11-58-51

What’s needed is creating a m3u playlist file with the RTSP stream URLs

#EXTM3U
#EXTINF:0,group-title="Kamera",Hatso resz
rtsp://admin:PASSWORD@192.168.88.3:6911/Streaming/Channels/101
#EXTINF:0,group-title="Kamera",Utca
rtsp://admin:PASSWORD@192.168.88.3:6911/Streaming/Channels/201

The m3u file can be uploaded via https://siptv.app/mylist/. You could upload it on a shared web hosting or on your own public web server that can realtime provide updated m3u file.

Installing Plex Media Server on a remote host

Finally nailed it. I installed Plex Media Server on a remote host and after visiting the http://REMOTE_HOST_IP:32400/web I had no add server option.

In a forum thread I found the add server URL part, just add #!/setup http://raspi:32400/web/index.html#!/setup
But I got Setup is not allowed for shared servers. error

ss_2018-09-30-08-28-38
Setup is not allowed for shared servers.

I ended up with port forwarding to the remote host
ssh -L 32400:raspi:32400

To be able to add server I had to connect to localhost http://localhost:32400/web/index.html#!/setup

Plex media server setup wizard

More info about troubleshooting remote access is atΒ https://support.plex.tv/articles/200931138-troubleshooting-remote-access/